ویرایشگر گوتنبرگ به انگلیسی Gutenberg در نسخه ۵ وردپرس فعال شد و توانست در مدت کوتاهی محبوبیت بالایی بین کاربران وردپرس پیدا کند. این ویرایشگر در نسخه ۵.۵ وردپرس با تغییرات بسیاری منتشر و مشکلات و کمبودهای بسیاری در آن برطرف شد. اما گوتنبرگ در برخی از افزونه های محبوب مانند ووکامرس که از ویرایشگر متن استفاده می کنند بصورت پیشفرض فعال نیست.

در این نوشته با یک تابع ساده، ویرایشگر گوتنبرگ را در ووکامرس فعال خواهیم کرد. تنها کافیست کد زیر را در فایل function.php پوسته خود قرار دهید.

function woocommerce_gutenberg($can_edit, $post_type){
	if($post_type == 'product'){
		$can_edit = true;
	}
	return $can_edit;
}
add_filter('use_block_editor_for_post_type', 'woocommerce_gutenberg', 10, 2);

مطالب مرتبط

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *